Service CRS seems to be down [PCI Bookings Failing]

Major incident CRS API Connects
2025-05-30 21:47 CEST · 3 hours, 53 minutes

Updates

Issue

The issue has been resolved, and we are now successfully receiving bookings. We will continue to monitor the system to ensure everything remains stable

May 31, 2025 · 01:40 CEST
Issue

Service CRS seems to be down [PCI Bookings Failing]

May 30, 2025 · 21:47 CEST

← Back