HRS Group Status
Subscribe
to updates
IHG Availability Request Failure
Minor incident
CRS API Connects
2025-10-21 13:52 CEST
· 1 hour, 33 minutes
Updates
Resolved
IHG service is back to normal now
October 21, 2025 · 15:24 CEST
Resolved
IHG service is back to normal now
October 21, 2025 · 15:24 CEST
Resolved
IHG service is back to normal now
October 21, 2025 · 15:24 CEST
Resolved
IHG service is back to normal now
October 21, 2025 · 15:24 CEST
Issue
IHG Availability Request Failure
October 21, 2025 · 13:52 CEST
← Back