Payment hub was down due to Microsoft Azure issue worldwide. We applied workaround and booking are coming through

Minor incident Payment Airplus Payment Hub AMEX Citibank
2025-10-29 18:02 CET · 53 minutes

Updates

Resolved

The service is up. All booking are coming through now.

October 29, 2025 · 18:53 CET
Update

Microsoft is resolving the issue, there is no ETA yet from their side.

However, we have applied a workaround to bypass Azure Front Door issue. Booking are going through, we are coming back slowly

October 29, 2025 · 18:37 CET
Issue

Microsoft is resolving the issue, there is no ETA yet from their side.

However, we have applied a workaround to bypass Azure Front Door issue. Booking are going through, we are coming back slowly

October 29, 2025 · 18:02 CET

← Back