HRS - Unplanned Maintenance - Services may become temporarily unavailable from 2026-03-31 15:00 CEST to 2026-04-07 20:50 CEST

Scheduled maintenance Connect Corporate Booking Portal HRS Web Service API HRS Concur API Mobile Hotel Service Portal Payment Airplus Payment Hub AMEX Citibank CRS API Connects GDS Apps Amadeus Cryptic Amadeus MS Sabre Travelport
2026-03-31 15:00 CEST · 1 week, 5 hours, 50 minutes

Updates

Resolved

Status: Resolved
Date: 5.4.2026
Update Time: 20:40 CEST

Our maintenance activity has now been completed and all services are confirmed as fully restored and operating as expected.

We thank you for your patience and understanding throughout this period.

April 7, 2026 · 20:49 CEST
Update

Status: In Progress
Date: 7.4.2026
Update Time: 9:20 CEST

Services are returning and are largely running as expected. Some services may experience temporary and minor disruption as we complete the final stages of our maintenance activity.

We anticipate maintenance will be completed by 19:00 CEST today.

We thank you for your continued patience and will provide a further update shortly.

HRS Product Operations

April 7, 2026 · 09:23 CEST
Update

Status: In Progress
Date: 6.4.2026
Update Time: 7:40 CEST

Services are returning and are largely running as expected. Some services may experience temporary and minor disruption as we complete the final stages of our maintenance activity.

We anticipate maintenance will be completed by 19:00 CEST today.

We thank you for your continued patience and will provide a further update shortly.

HRS Product Operations

April 6, 2026 · 07:40 CEST
Update

We are pleased to advise that services are largely running as expected. Some services may experience temporary and minor disruption as we complete the final stages of our maintenance activity.

We anticipate maintenance will be completed by 19:00 CEST on 5.4.2026.

We appreciate your patience throughout and will provide a further update shortly.

HRS Product Operations

April 5, 2026 · 08:52 CEST
Update

Status: In Progress
Date: 3.4.2026
Time: 15:00 CEST
Expected Duration: 4.4 26 19:00 CEST

We are continuing our unplanned maintenance across our products and services. During this time, services may not be available.

We will be providing regular updates throughout the maintenance window, including details on which specific products and services are impacted and when they are expected to return.

We apologise for any inconvenience this may cause and thank you for your patience.

HRs Product Operations

April 3, 2026 · 15:26 CEST
Monitoring

Status: Restoring
Date: 2.4.2026
Update Time: 8:00 CEST

We are pleased to advise that services are largely running as expected. Some services may experience temporary and minor disruption as we complete the final stages of our maintenance activity.

We anticipate maintenance will be completed by 19:00 CEST on 2.4.2026.

We appreciate your patience throughout and will provide a further update shortly.

April 2, 2026 · 08:02 CEST
Update

Status: Restoring
Date: 1.4.2026
Update Time: 13:00 CEST

We are pleased to advise that services are largely running as expected. Some services may experience temporary and minor disruption as we complete the final stages of our maintenance activity.

We appreciate your patience throughout and will provide a further update shortly.

HRS Product Operations

April 1, 2026 · 13:03 CEST
Update

Status: In Progress
Date: 1.4.2026
Update Time: 09:55

We are providing an update on our ongoing maintenance. There are no changes to report at this time, however we can confirm that the maintenance window has been extended beyond the original estimate to 19:00 CEST today.

We will provide a further update as soon as more information is available.

We thank you for your continued patience.

HRS Product Operations

April 1, 2026 · 09:52 CEST
Essential

Status: In Progress
Date: 31.3.2026
Time: 15:00 CEST
Expected Duration: 10 Hours

We are currently carrying out unplanned maintenance across our products and services. During this time, services will not be available.

We will be providing regular updates throughout the maintenance window, including details on which specific products and services are impacted and when they are expected to return.

We apologise for any inconvenience this may cause and thank you for your patience.

HRS Product Operations

March 31, 2026 · 15:04 CEST

← Back